*

Eclipse(4.3,4.4)の使い方[各画面エリアの名称とパースペクティブのビューのカスタマイズ]

公開日: : 最終更新日:2015/05/01 Eclipse, Java


スポンサードリンク



本エントリーでは、Eclipse(Eclipse4.3,4.4)の各画面エリアの名称の説明と、ビューのカスタマイズ方法を説明させていただきます。

なお、各機能に関する詳細な利用方法は別エントリーを作成いたしますので、
表面的な説明しか記載しないことをご了承ください。

1 各画面エリアの名称と基礎知識

Eclipseの画面の基礎知識

Eclipseは画面上部にある固定エリアと「ワークベンチ」で構成されます。
「ワークベンチ」にはただ1つの「パースペクティブ」が表示されます。

パースペクティブの例としては

  • Java(コーディングを行う時はこれ)
  • デバッグ
  • Git

等があります。

それぞれの「パースペクティブ」は、対応する動作を行うための複数のサブウィンドウを保持しています。
サブウィンドウは、「ビュー」または「エディタ」が表示される領域です。

Javaパースペクティブのデフォルトのワークベンチは以下の通りです。
01基本画面

デバッグパースペクティブのデフォルトのワークベンチは以下の通りです。
06パースぺくティブを開く(デバッグ)

なお、「ビュー」が表示されるサブウィンドウには、タブ形式で複数「ビュー」が属することが一般的で
サブウィンドウに表示する「ビュー」を切り替えることが可能です。
01基本画面

メニューバーとツールバー

画面上方にある2つのバーが「メニューバー」と「ツールバー」です。
01基本画面

メニューバーには、Eclipseの全ての操作を行うメニューが格納されています。
ツールバーには、Eclipseを利用する時に、頻繁に利用する操作へのショートカット的なメニューが格納されています。

クイック・アクセス

「クイック・アクセス」は以下の画像の赤枠部分です。
01基本画面

ここに、何かやりたいことに関するキーワードを入力すると、対応する操作の候補を一覧で表示してくれます。
例えば”ファイル”と入力した場合は以下のように表示されます。
40クイックアクセス(ファイル)

なかなか便利です。ファイル作成やファイル検索等の操作の候補が表示されています。
表示されている任意の行をクリックすると、行に表示されている処理が実施可能です。

パースペクティブ・クイックアクセス

正式な名称は不明ですが・・・
パースペクティブの表示、切り替えが素早くできます。
01基本画面

パースペクティブを開く

以下の赤枠部分をクリックするパースペクティブの選択画面が表示され、パースペクティブを素早く開くことができます。
01基本画面

パースペクティブの選択画面
42パースペクティブを開く

パースペクティブの切り替え

既に開いたことがある「パースペクティブ」が以下の画像の赤枠部分に表示されますので、
任意の「パースペクティブ」をクリックすることで、「パースペクティブ」の切り替えが素早くできます。
01基本画面

2 パースペクティブのビュー関連のカスタマイズ

Javaパースペクティブのデフォルトの表示を色々変更してみたいと思います。

ビューを移動することで、そのビューが属するウィンドウを変更することが可能です。
ビューの移動方法によっては新規のウィンドウが生成されることもあります。
「問題」ビューをウィンドウAからウィンドウBに移動するみたいな変更が可能です。

ビューの削除

ビューの削除は、ビューを選択し「×」ボタンをクリックするか
01基本画面

タブを右クリックして表示されるメニューの削除をクリックすることで可能です。
10JavaDocを閉じるにはメニューから

上記画像では、「問題」、「Javadoc」、「コンソール」のビューが属しているウィンドウが存在しており、
「Javadoc」の「閉じる」メニューを表示していいます。実際に「閉じる」をクリックすると
以下の画像のように「Javadoc」ビューが表示されなくなります。
11JavaDocを閉じた後

ビューの表示

Eclipseのメニューの文言は「ビューの表示」ですが、実際はビューの追加のイメージの方が近いと思います。

ビューの表示方法

「ビューの表示」は、[ウィンドウ]>[ビューの表示]とクリックします。
09っビュー゙を開く(一覧)

よく利用するビューが一覧で表示されています。任意のビューをクリックしてください。
これで選択したビューがウィンドウに追加されます。

あまり利用しないビューは「その他」にまとめられています。

「その他」をクリックすると、画面が表示され、様々なビューが表示可能となります。
25ビューその他選択

「その他」をクリックした時に表示される「ビューの表示」画面
26ビューその他表示

ビューの表示」画面で「一般」を展開した時の画面イメージは以下の通りです。
表示したビューを選択して「OK」ボタンを押せばビューが追加されます。
27ビューその他(一般展開)

「ビューの表示」画面で「Git」を展開した時の画面イメージ
28ビューその他(Git展開)

ビューの追加方法についてはご理解いただけたと思います。
しかし、ここで疑問がわいてくると思います。いったいどこのウィンドウに追加されるんだ!?と

ビューが表示される場所

以下のメニューをクリックして「Javdoc」ビューを表示してみます。
12JavaDocを再度表示

表示後の画面は、以下のようになりました。
13JavaDocを再度表示.後png

上記の画像を見ていただいて分かる通り、ビューは、そのビューが以前属していウィンドウに追加されました。

実際には、デフォルトの表示ウィンドウがまず候補として認識され、
ビューがデフォルトのウィンドウから移動されていれば、そのウィンドウが優先となります。

ビューの移動については後述されていただきます。

同じように「プロジェクト・エクスプローラー」ビューを表示してみます。
14プロジェクト・エクスプローラー表示メニュークリック

「プロジェクト・エクスプローラー」ビューは左端のウィンドウに追加されました。
ここが「プロジェクト・エクスプローラー」ビューのデフォルトの格納ウィンドウだからです。
15プロジェクト・エクスプローラー表示後

ビューの移動

次はビューの移動の説明をさせていただきます。

「Javadoc」ビューを他のウィンドウに移動しようと思いますので、
「Javadoc」ビューを右クリックで選択し、以下の画像のようにドラッグします。
16JavaDoc移動前

すると画面は以下のように変わるはずです。
17JavaDoc移動(パターン1)

右端にあるウィンドウが黄緑色の縦に並んだ枠2つで分割されています。
この状態でドロップします。

すると画面は以下のようになりました。
右端の上に新しいウィンドウが作成され、そこに「Javadoc」ビューが格納されました。
18JavaDoc(パターン1で閉じる)

先ほどの例は、新たなウィンドウが作成されるビューの移動でしたが、既存のウィンドウに
「Javadoc」ビューを移動することも可能です。
ドラッグする場所を以下の画像の赤枠部分にすると、「アウトライン」ビューの左側に黄緑の縦線が表示されます。
23JavaDoc移動(パターン2)

この状態でドロップします。
すると画面は以下のようになりました。
24JavaDoc移動後(パターン1)

ドロップする場所を変えれば、以下のような場所にも配置可能です。
23JavaDoc移動(パターン1)

ビューとウィンドウの関係の確認

ここで再度「Javadoc」ビューを閉じてから表示してみようと思います。

「Javadoc」ビューが表示されているウィンドウは、「Javadoc」ビューしか属していないので、
「Javadoc」ビューが閉じられると、このウィンドウはどうなるのでようか?

まずビューの「×」ボタンをクリックして閉じます。
18JavaDoc移動後(パターン1)

「Javadoc」ビューが閉じられた後の画面は以下のようになりました。
「Javadoc」ビューしか属していないウィンドウは「Javadoc」ビューとともに消えました。
20JavaDoc移動後(パターン1で閉じた後)

ここで再度、「Javadoc」ビューを表示するとどうなるでしょうか?
21JavaDoc移動後(パターン1で表示)

先ほどと同じ場所にビューもウィンドウも表示されました。
22JavaDoc移動後(パターン1で表示後)

先ほど記載した。
デフォルトの表示ウィンドウがまず候補として認識され、ビューがデフォルトのウィンドウから移動されていれば、
そのウィンドウが優先となります。
との説明の通りの動きですね。

かつ、ウィンドウがその場所に存在しなければ、ウィンドウを作成してビューが追加されることが確認できました。

パースペクティブのリセット

いろいろビューを動かしてみたけど、やっぱりデフォルトに戻したい!
と思う事もあるかもしれません。

そんな時のために、Eclipseはパースペクティブのリセットメニューを用意してくれています。

現在のJavaパースペクティブが以下のような構成になっているとします。
36エクスプローラ下バージョン

[ウィンドウ]>[パースペクティブのリセット]をクリックします。
37パースペクティブのリセットメニュー

パースペクティブがリセット確認ダイアログが表示されますので、「はい」をクリックしてください。
38パースペクティブのリセット確認

パースペクティブが元にもどりました。
39パースペクティブのリセット後

「Eclipse(4.3)の使い方[各画面エリアの名称とパースペクティブのカスタマイズ]」は以上です。


スポンサードリンク



関連記事

Java超入門 with Eclipse[3:クラスに関する基礎知識(クラスとインスタンスとパッケージ)]

Javaといえば、「オブジェクト指向」とのイメージがとっても強いですよね。 そう、そうです。間違い

記事を読む

JUnit入門その9[@RunWithアノテーションを利用したテストの作成]

今回は@RunWithアノテーションを利用したテストの作成方法を説明させていただきます。 JU

記事を読む

お勧め本紹介[新装版 リファクタリング―既存のコードを安全に改善する― (OBJECT TECHNOLOGY SERIES)]

リファクタリング―プログラムの体質改善テクニック (Object Technology Series

記事を読む

JUnit入門その4[Eclipse4.4のJUnitプラグインとDBUnitの併用(環境構築と基本)]

JUnit入門その1 JUnit入門その2[Eclipse4.4のJUnitプラグインのasse

記事を読む

Selenium入門その5[ページオブジェクトパターン(Page Object Design Pattern)を利用して変更に強いテストを作成する方法]

Selenium入門その2 では「UIマップファイル」と言う仕組みが存在していることに言及させてい

記事を読む

Eclipse(4.3,4.4)のJava言語のリファクタリング機能の使い方[リファクタリングの説明と「名前変更」と「移動」]

本エントリーでは、Eclipse(4.3,4.4)の「リファクタリング」機能の使い方を説明させていた

記事を読む

JUnit入門その6[Eclipse4.4のJUnitプラグインとDBUnitの併用(便利に利用するためのユーティリティの作成)]

JUnit入門その4 でDBUnitの環境構築を説明させていただきました。 今回は、前提値デ

記事を読む

Java8のラムダ式とStream APIを利用してコーディング量の削減サンプル集

Java8になりラムダ式と「Stream API」が利用できるようになりました。 C#では一足早く

記事を読む

Java超入門 with Eclipse[2:プリミティブ型(基本データ型)とは]

他のプログラミング言語と同様に、Javaにもデータ型が存在します。 Java超入門の第2回では、プ

記事を読む

Eclipseのインストールと日本語化とJDK8(Java8)対応[Eclipse4.4とEclipse4.3]

インストールするEclipseのバージョンですが、とりあえず4.3をターゲットとしておき、 4.4

記事を読む

Message

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Selenium入門その6[Selenium3でWebDriver(Java/Junit4)の環境を作成しEdge,Chrome,Firefoxで確認してみる]

Selenium3も3.0.1がリリースされましたし、今後は本格的にS

Selenium利用時のトラブルシューティング方法[クリック編]

Seleniumは便利なテスト自動化ツールですし、今後は更なる利用者の

Java8のラムダ式とStream APIを利用してコーディング量の削減サンプル集

Java8になりラムダ式と「Stream API」が利用できるようにな

Selenium入門その5[ページオブジェクトパターン(Page Object Design Pattern)を利用して変更に強いテストを作成する方法]

Selenium入門その2 では「UIマップファイル」と言う仕組みが

Javaによる非同期処理入門その1[非同期処理の実装方法の概説]

Javaによる非同期処理に関するエントリーを前々から作成したいと思って

→もっと見る

Optimization WordPress Plugins & Solutions by W3 EDGE
PAGE TOP ↑