*

Eclipse(4.3,4.4)の使い方[パースペクティブのツールバーのカスタマイズ(「コマンド・グループ可用性」と「ショートカット」タブ)]

公開日: : 最終更新日:2015/05/03 Eclipse, Java


スポンサードリンク



「パースペクティブのカスタマイズ」画面には、以下の4つのタブが存在しております。

  1. ツール・バー可視性
  2. メニュー可視性
  3. コマンド・グループ可用性
  4. ショートカット

 

前回エントリー「Eclipse(4.3)の使い方[パースペクティブのツールバーのカスタマイズ(「ツール・バー可視性」と「メニュー可視性」タブ)]では、
「コマンド・グループ可用性」と「ショートカット」タブの使い方を説明させていただきました。

今回は、残りの「コマンド・グループ可用性」と「ショートカット」のカスタマイズの説明をさせていただきます。

3 コマンド・グループ可用性

見出しの番号はタブの並び順と同じとしておりますので、敢えて3としています。

「コマンド・グループ可用性」タブの画面構成と概要の説明

「コマンド・グループ可用性」タブの画面構成は以下の通りです。
31コマンド・グループの可溶性

左端に、「使用可能なコマンド・グループ」の一覧(チェックボックス付き)があり、
真ん中に、「メニュー・バー詳細」のエリア、
右端に、「ツール・バー詳細」エリアがあります。

「使用可能なコマンド・グループ」で選択している項目に対応した内容が
「メニュー・バー詳細」と「ツール・バー詳細」に表示されます。

「使用可能なコマンド・グループ」に表示される内容

どの「使用可能なコマンド・グループ」の項目を選択しても、「メニュー・バー詳細」には何も表示されません。
Eclipseの今後のレベルアップで実装する予定なのか、バグっているのか判断しかねます。
普通、レベルアップで利用するエリアであれば、非表示にするぐらいの対処をしてしかるべきなのですが・・・

「ツール・バー詳細」に表示される内容

選択されている「使用可能なコマンド・グループ」の項目に、対応するツール・バーに表示される
アイコンとテキストが表示されます。ルートのアイコンは、どの項目を選択しているかを分かりやすくするために
存在しており、特に意味はありません。

以下の画像から、「Javaエディターの表示」には、「パンくずリストの切り替え」と「出現箇所のマークのトグル」
が属していることが分かります。
31コマンド・グループの可溶性

画面の利用方法

画面の利用方法につきましては、特に迷うところはないと思います。
有効・無効を変更したい「使用可能なコマンド・グループ」の項目を選択し、
その項目のチェックボックスの状態を変更(有効にしたいならチェック、無効にしたいなら未チェック)し
「OK」ボタンをクリックするだけです。

コマンド・グループの「Javaエディター表示」を無効化

実際に、「Javaエディター表示」を無効化し、Eclipseの各エリアがどのように変わるかを確認してみます。

と言っても、明らかにツール・バーに影響があることは明らかですので、ツール・バーを先に確認しておきます。
「パンくずリストの切り替え」と「出現箇所のマークのトグル」は以下の画像の赤枠部分に表示されています。
32コマンド・グループの可溶性

「Javaエディター表示」を無効化します。
コマンド・グループの「Javaエディター表示」を選択し、チェックを外し、「OK」ボタンをクリックします。
33コマンド・グループの可溶性

すると、ツール・バーから「パンくずリストの切り替え」と「出現箇所のマークのトグル」アイコンがなくなりました。
35コマンド・グループの可溶性

もう1つ、この操作で影響を受けたところがあります。
「パースペクティブのカスタマイズ」画面の「ツール・バー可視性」タブの「エディタ表示」の配下の要素です。
34コマンド・グループの可溶性

すこし見にくいですが、「パンくずリストの切り替え」と「出現箇所のマークのトグル」がグレーアウトされています。
「Javaエディター表示」を無効化するという行為が直接的に、ツール・バーの2つのアイコンを非表示にするわけではなく、「ツール・バー可視性」で表示化できないから、結果的に非表示になったという事です。

4 ショートカット

「ショートカット」タブの画面構成

「ショートカット」タブの画面構成は以下の通りです。
ショートカットのサブメニュー(新規)

といっても、「ショートカット」タブにはサブメニューがあり、選択するサブメニューによって
設定の変更内容が大きく変化します。

選択可能なサブメニューは以下の通りで、「新規」、「パースペクティブ」、「ビューの表示」の3つです。
ショートカットのサブメニュー

サブメニューで「新規」選択時の画面

Eclipseのメニューの[ファイル]>[新規]から新規作成可能なファイルのショートカットを編集する画面です。
ショートカットのサブメニュー(新規)

サブメニューで「パースペクティブを開く」選択時の画面

Eclipseのメニューの[ウィンドウ]>[パースペクティブを開く]から、直接開くことが可能なパースペクティブを編集する画面です。
ショートカットのサブメニュー(パースペクティブを開く)

サブメニューで「ビューの表示」選択時の画面

Eclipseのメニューの[ウィンドウ]>[ビューの表示]から、直接指定可能なビューを編集する画面です。
ショートカットのサブメニュー(ビューの表示)

「ショートカット」タブの使い方

サブメニュー「新規」選択時の設定の反映先

この設定がどこに反映されるかを説明いたします。
って、先ほど書いたまんまですが、Eclipseのメニューの[ファイル]>[新規]
から新規作成可能なファイルのショートカットとなります。

実際のメニューは以下の画像の赤枠部分となります。
40ショートカット

対応する設定画面は以下の通りです。
39ショートカット

上記の2画面を見比べていただくと分かると思いますが
「ショートカット」の設定画面のカテゴリー「Java」を選択している時の
ショートカット一覧とのチェックボックスがONの項目と[ファイル]>[新規]に表示されている内容が一致しています。

ショートカット一覧でチェッックされているショートカットは

  • Javaプロジェクト
  • Javaワーキンング・セット
  • インターフェース
  • クラス
  • ソース・フォルダー
  • パッケージ
  • 注釈
  • 列挙型

となっており、Eclipseのメニューの[ファイル]>[新規]と一致しています。
とはいっても、ショートカット・カテゴリーの「一般」で管理されているショートカットも存在するので、
完全に一致はしていません。

「プロジェクト」、「フォルダー」はショートカット・カテゴリーの「一般」で管理されているショートカットです。

「新規」のJavaショートカットを実際に変更

以下のようにチェック状態を変更し、「OK」ボタンをクリックします。
41ショートカット

先ほど表示されていた、Javaプロジェクト、Javaワーキンング・セット、インターフェース、
クラス、ソース・フォルダー、パッケージ、注釈が表示されなくなり、列挙型だけ表示されるはずです。

実際のメニューのショートカットは以下のようになりました。
うん、うん、予想通りですね。
42ショートカット

実は、この設定はツール・バーの新規ファイルのショートカットにも反映されます。

以下の画像の赤枠部分をクリックすると、新規ファイル作成のショートカットが表示されます。
43ショートカット

実際の表示内容は以下のようになりました。メニューの[ファイル]>[新規]と同じ一覧ですね。
44ショートカット

サブメニュー「ビューの表示」選択時の設定の反映先

この設定の反映先は、Eclipseのメニューの[ウィンドウ]>[ビューの表示]の配下に表示されるショートカットとなります。
44ショートカット(ビュー)

サブメニュー「ビューの表示」選択時の設定変更

実際に、設定を変更して、[ウィンドウ]>[ビューの表示]の配下に表示されるショートカットに反映されるか確認してみます。

とここでお詫びです。
ビューの表示のショートカット・カテゴリーを選択すると、右側のショートカット一覧に、
選択したショートカット・カテゴリーに属するショートカットが表示されるのですが、画面イメージ取得してませんでした。

当然、複数のショートカットのチェック状態を変更して設定変更をすることも可能です。

今回は、「Ant」ショートカットを非表示にしてみます。理由は、メニューのショートカットの1番目にあるからです。
44ショートカット(ビュー)

設定画面で「Ant」ショートカットのチェックを外し、「OK」ボタンをクリックします。
ショートカット・カテゴリーの「Ant」には属するショートカットは1つしかないので、
こちらの「Ant」の左のチェックを外しても、ショートカット一覧の「Ant」の左のチェックを外しても結果的には同じです。
46ショートカット

設定変更後のEclipseの[ウィンドウ]>[ビューの表示]は以下のように変わりました。
「コンソール」の上に表示されていた「Ant」が表示されなくなりました。
47ショートカット

サブメニュー「パースペクティブを開く」選択時の設定の反映先

この設定の反映先は、Eclipseのメニューの[ウィンドウ]>[パースペクティブを開く]の配下に表示されるショートカットとなります。
48パースペクティブ

設定の反映先と設定方法は「ビューの表示」メニューとほぼ同じですので、特に説明は必要ないと思います。
最後に設定画面を復習して終わりにしたいと思います。
ショートカットのサブメニュー(ビューの表示)

以上で、Eclipse(4.3)の使い方[パースペクティブのツールバーのカスタマイズ(「コマンド・グループ可用性」と「ショートカット」タブ)]は終了です。


スポンサードリンク



関連記事

Eclipseの「DBViewer」プラグインを利用して「Java DB」の環境を作成し、SQLを発行してみる

EclipseのJUnitプラグインとDBUnitを併用したDB(データベース)のアクセス処理のユニ

記事を読む

JUnit入門その1[Eclipse4.4のJUnitプラグインの基本的な使い方]

利用する環境の作成につきましては、「Eclipseの使い方(Windows環境のEclipse4.3

記事を読む

Eclipse4.4(Java)におけるビルド・パス関係の設定方法[ビルド・パス上のソース・フォルダー]

Eclipse4.4(Java)におけるビルド関係のビルド・パス上のソース・フォルダーの利用方法を説

記事を読む

Eclipse(4.3)の使い方[パースペクティブのツールバーのカスタマイズ(「ツール・バー可視性」と「メニュー可視性」タブ)]

前回エントリー「Eclipse(4.3)の使い方[各画面エリアの名称とパースペクティブのカスタマイズ

記事を読む

Eclipse(4.4)でJava言語のリファクタリング機能の使い方[「メソッド・シグニチャーの変更」と基本的な抽出処理、及び「インライン化」、「定数の抽出」]

本エントリーでは、Eclipse(4.3)でJava言語のリファクタリング機能の使い方に引き続き

記事を読む

利用すると生産性が格段に向上する厳選Eclipseショートカット集

今回のエントリーは、利用すると生産性が格段に向上するEclipseのショートカット集となります。

記事を読む

Eclipse4.4(Java)におけるビルド・パス関係の設定方法[ビルド・パス上に必要なプロジェクト/プロジェクト参照の追加]

Eclipse4.4(Java)におけるビルド関係のビルド・パス上の「ビルド・パス上に必要なプロジェ

記事を読む

Java超入門 with Eclipse[5:クラスに関する基礎知識(メソッドをJUnitを使って説明)]

クラスに関する基礎知識シリーズも、いよいよメソッドを残すのみとなりました。 前回までは、Eclip

記事を読む

JDK8(java 8)の新機能のラムダ式の利用方法[その3:java8が用意している関数型インターフェース]

[その2:関数型インターフェースを例としたラムダ式] と説明させていただいておりますが、

記事を読む

JDK8(Java8)のインストール方法[Windows]

本エントリーは、Windows7 64bitにJDK8(Java8)をインストールする説明を記載させ

記事を読む

Message

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Selenium入門その6[Selenium3でWebDriver(Java/Junit4)の環境を作成しEdge,Chrome,Firefoxで確認してみる]

Selenium3も3.0.1がリリースされましたし、今後は本格的にS

Selenium利用時のトラブルシューティング方法[クリック編]

Seleniumは便利なテスト自動化ツールですし、今後は更なる利用者の

Java8のラムダ式とStream APIを利用してコーディング量の削減サンプル集

Java8になりラムダ式と「Stream API」が利用できるようにな

Selenium入門その5[ページオブジェクトパターン(Page Object Design Pattern)を利用して変更に強いテストを作成する方法]

Selenium入門その2 では「UIマップファイル」と言う仕組みが

Javaによる非同期処理入門その1[非同期処理の実装方法の概説]

Javaによる非同期処理に関するエントリーを前々から作成したいと思って

→もっと見る

Optimization WordPress Plugins & Solutions by W3 EDGE
PAGE TOP ↑